WebLogic 12c – Changes to Domain Configuration Lost on Server Reboot

Had this weird issue where every time I’d made elaborate deployments and configuration changes in WebLogic Console, they’d miraculously disappear on server reboot.

Naturally, this is extremely infuriating considering the time it takes to deploy/configure just about ANYTHING in WebLogic.

So basically, I did some snooping around in the file structure after just about going insane and found this little diddy in the domain structure of the root.

/home/oracle/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/domain_bak/config_prev/config.xml

I had read on this guys blog that he had a similar issue essentially:

Somehow, every time I applied changes even after deleting this pesky file the folder and backup file kept getting created and reverting ALL the changes on reboot and successful activation.

I got fed up.

As a provisional/permanent fix, I added a small line before invoking the startWebLogic.sh which is below.

rm -Rf /home/oracle/Oracle/Middleware/Oracle_Home/user_projects/domains/base_domain/servers/domain_bak/*

Fixed my issue and worked like a charm.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s